Moving OpenVpn server to new hardware

I’ve been running a windows OpenVpn server for over 5 years now. Part of that as a VM and for the last 3 years or so on dedicated hardware. That hardware consisted of an old Dell desktop PC running Windows XP. It was an emergency setup that I just never got back around to fixing permanently. So this week I decided to migrate it to one of my Hyper-V hosts and run it on a 2008r2 Std.  VM. I’ve always ran OpenVpn in bridged mode, so when I tried to create the bridge in 2008r2 I found that I would lose network connectivity. I tried deleting and recreating the bridge several times along with multiple reboots, always with the same results. After much googling I ran across an article describing this problem in server 2003r2 and a link to another article describing how to force the TAP nic into compatibility mode due to some NICs not automatically entering into Promiscuous mode which causes the bridge not to be able to pass traiffic. The fix for me was forcing compatability mode on the Microsoft Hyper-V adapter instead of the virtual OpenVpn TAP adapter. To do this simply open an elevated command prompt and type “netsh bridge show adapter” then locate the identification number of the NIC you wish to put into compatibility mode. Next type the following command substituting the number of your prefered NIC for the 1 “netsh bridge set adapter 1 forcecompatmode=enable”  Next run the “netsh bridge show adapter” command again to verify that the ForceCompatabilityMode field for the NIC is displayed as Enabled.

 

Leave a Reply

Your email address will not be published.